Проблеми с форума

Всички останали въпроси и теми.
OldschoolBG
Power User
Power User
Мнения: 1102
Регистриран: 30 яну 2008 11:10
Местоположение: България
Контакти:

Re: Проблеми с форума

Мнение от OldschoolBG » 07 апр 2013 02:57

aSmith написа:Не знам колко е нормално, но преди човек можеше да цъкне "Запомни ме" и да не се занимава повече с логване в сайта.
В момента това не е така и е доста дразнещо да трябва да се логваш всеки път за да видиш дали някой е написал нещо.
Запомнянето трябва да работи, но понякога нещо се бъгва. Във форума на PHPBB3 има не една и две теми, в който се говори точно за това. Колкото до виждането дали някой е поствал можеш да правиш като мен и просто да поглеждаш датите на последните постове в индекса.

Stilgar
Power User
Power User
Мнения: 824
Регистриран: 12 яну 2006 22:15
Контакти:

Re: Проблеми с форума

Мнение от Stilgar » 07 апр 2013 03:28

Не е нормално ID-то да е в URL-то. Т'ва е fallback механизъм от праисторията за браузъри, които не поддържат cookies или cookies са забранени. Според мен заради някакъв бъг форумът смята, че някой браузъри не поддържат cookies и слага нещата в URL-то. Например ако прави някакво лексикографско сравнение на версията и при което IE3 > IE10 или някаква подобна простотия.

ikolev
модератор
модератор
Мнения: 1659
Регистриран: 20 ное 2003 22:39
Местоположение: София
Контакти:

Re: Проблеми с форума

Мнение от ikolev » 07 апр 2013 10:25

OldschoolBG написа:Това поле къде се намира в АCP-а? Питам, защото аз съм с 3.0.11 версия и не го намерих в Board Settings->Load Settings.
Ами май е точно там. При мен всичко е на български, така че се намира в първия таб - "Основни", последната група в менюто отляво - "Конфигурация на сървъра", четвъртата опция - "Настройки зареждане". Втората настройка е "Дължина на сесия".

Сега и аз пробвах да вляза със "запомни ме", да видим дали ще ми иска парола след час.

Явно SID-а го има в URL-то на всички браузъри, така че по-скоро изглежда да е сложен нарочно. Не ме карайте да чета РНР за да разбера кой го слага там. Пък и не виждам какъв е проблемът от това. Причината да не запомня логина сигурно е другаде.
И освен това, от къде тоя интерес че да проверявате по 10 пъти на ден дали някой не е писал нещо... ;)

Потребителски аватар
themean
Power User
Power User
Мнения: 860
Регистриран: 02 дек 2010 22:51

Re: Проблеми с форума

Мнение от themean » 07 апр 2013 12:15

ikolev написа: И освен това, от къде тоя интерес че да проверявате по 10 пъти на ден дали някой не е писал нещо... ;)
Ми..., аз го правя :)

OldschoolBG
Power User
Power User
Мнения: 1102
Регистриран: 30 яну 2008 11:10
Местоположение: България
Контакти:

Re: Проблеми с форума

Мнение от OldschoolBG » 07 апр 2013 16:12

@ikolev дам, там било. То трябвало с founder да бъдеш, за да ти го покаже.

BTW махнах SID на моя форум. Ето как:

1. Отиваш в ACP ==> Tab "General" ==> Server configuration ==> Cookie settings
2. Cookie domain: .gamedev-bg.net (обърни внимание на точката, която е в началото на домейна. Трябва да е там, тъй като адреса на форума тук е: http://gamedev-bg.net/phpBB3)
3. Cookie name: cookiename_example (пишеш нещо оригинално като gamedev_bg или го оставяш както е)
4. Cookie path: / (винаги е наклонена черта, без значение какъв е адресът на форума)
5. Cookie Secure: В повечето случаи е "Disabled", но ако форумът използва SSL трябва да е "Enabled".

След като направиш промените всеки трябва да си изтрие цookie-то за сайта/форума от браузъра. Ако е направено както трябва при вписване и зареждане на индекса на форума в URL-а излиза SID-а. Когато, обаче отидеш на друга страница (влезеш в секция или пост) или се върнеш отново на индекса SID-а вече не се показва.

SuryIIID
Power User
Power User
Мнения: 431
Регистриран: 01 яну 2004 21:03
Местоположение: София
Контакти:

Re: Проблеми с форума

Мнение от SuryIIID » 07 апр 2013 17:48

ikolev написа:
OldschoolBG написа:Това поле къде се намира в АCP-а? Питам, защото аз съм с 3.0.11 версия и не го намерих в Board Settings->Load Settings.
Ами май е точно там. При мен всичко е на български, така че се намира в първия таб - "Основни", последната група в менюто отляво - "Конфигурация на сървъра", четвъртата опция - "Настройки зареждане". Втората настройка е "Дължина на сесия".
Сега и аз пробвах да вляза със "запомни ме", да видим дали ще ми иска парола след час.
Относно пролема "запомни ме" забелязах на моя форум, че в "General" (Основен) таб-а, в Security settings секцията, първата опция (Allow persistent logins:
Determines whether users can autologin when they visit the board.) е включена при мен и помни.

ikolev
модератор
модератор
Мнения: 1659
Регистриран: 20 ное 2003 22:39
Местоположение: София
Контакти:

Re: Проблеми с форума

Мнение от ikolev » 08 апр 2013 19:06

@OldschoolBG - значи доколкото разбирам единствената разлика е в точката пред домейна? Защото тук я нямаше. Сложих я, но не виждам нещо да се е променило, sid-а си излиза в URL-то постоянно. Опцията за сигурност е включена, може би защото сървъра поддържа SSL. Дали форума го ползва - не знам, не съм виждал някога https в адреса.
SuryIIID написа:Относно пролема "запомни ме" забелязах на моя форум, че в "General" (Основен) таб-а, в Security settings секцията, първата опция (Allow persistent logins:
Determines whether users can autologin when they visit the board.) е включена при мен и помни.
И тук опцията е включена, но явно не работи.

OldschoolBG
Power User
Power User
Мнения: 1102
Регистриран: 30 яну 2008 11:10
Местоположение: България
Контакти:

Re: Проблеми с форума

Мнение от OldschoolBG » 08 апр 2013 22:20

@ikolev сега и аз проверих. Изтрих си cookie-то от браузъра, но SID-а се показва. Не знам дали SSL опцията има отношение към това, но ако искаш я спри и виж така как ще е. При мен само сложих точката пред домейна понеже е във формат www, опцията за SSL си беше изключена. SID излиза само при вписване на индекса, след това го няма.

aSmith
Regular User
Regular User
Мнения: 80
Регистриран: 11 авг 2004 20:09
Местоположение: София

Re: Проблеми с форума

Мнение от aSmith » 09 апр 2013 02:21

ikolev написа:И тук опцията е включена, но явно не работи.
Преди работеше, нещо в последния месец два се е счупило. Ползвам Firefox 12, 18-20.

А аз не искам да проверявам форума през 10 мин, а като го проверявам да не ме пита за парола.

SuryIIID
Power User
Power User
Мнения: 431
Регистриран: 01 яну 2004 21:03
Местоположение: София
Контакти:

Re: Проблеми с форума

Мнение от SuryIIID » 09 апр 2013 08:21

Доколкото виждам кукитата от gamedev-bg.net не са алфанумерик+underscore, а имат паузи. Става дума за "Cookie name".
Пробвай с нещо phpbb3_jrsd8. Също ми прави впечатление, че при преглед с Хром не са HttpOnly.

Едит: Май само така ми се вижда в таблицата на Хром...

ikolev
модератор
модератор
Мнения: 1659
Регистриран: 20 ное 2003 22:39
Местоположение: София
Контакти:

Re: Проблеми с форума

Мнение от ikolev » 10 апр 2013 13:24

Изключих сигурността и махнах тирето в името. Май работи сега - поне като отворя нова страница (без SID в адреса) си оставам логнат.

OldschoolBG
Power User
Power User
Мнения: 1102
Регистриран: 30 яну 2008 11:10
Местоположение: България
Контакти:

Re: Проблеми с форума

Мнение от OldschoolBG » 10 апр 2013 14:34

Да, няма SID.

Потребителски аватар
KosSiO
Power User
Power User
Мнения: 317
Регистриран: 20 окт 2008 19:29
Местоположение: Targovishte,Sofia

Re: Проблеми с форума

Мнение от KosSiO » 10 апр 2013 15:53

При мен е песен! Мерси!

Stilgar
Power User
Power User
Мнения: 824
Регистриран: 12 яну 2006 22:15
Контакти:

Re: Проблеми с форума

Мнение от Stilgar » 10 апр 2013 15:55

Евала!

Потребителски аватар
themean
Power User
Power User
Мнения: 860
Регистриран: 02 дек 2010 22:51

Re: Проблеми с форума

Мнение от themean » 10 апр 2013 16:12

@ikolev
Ти си моя герой :)

Отговори